Here are some useful tricks to reduce the effort of migrating code 4.x to the newest 5.x series.

Ignore tenant scope

Now the tenant scope is deprecated. If you are using Spring bean autoscanning you can use the following configuration to avoid removing the scope from every old class:

<context:component-scan base-package="org.areco.ecommerce.deploymentscripts" scope-resolver="de.hybris.platform.spring.IgnoreTenantScopeMetadataResolver"/>

Based on Hybris 5.2

Add comment


Security code
Refresh